• 666 Players on Java
  • us.mineplex.com
  • 8466 Players Online
  • 7800 Players on Bedrock
  • pe.mineplex.com
!
Attention Internet Explorer Users
To have the best user experience on our site please consider upgrading to Google Chrome or Mozilla Firefox

Huge Fps Drops

Discussion in 'Super Smash Mobs' started by Bozidqr, Feb 6, 2019.

Thread Status:
Not open for further replies.
  1. Hello everyone!
    Recently, when i play SSM and when smash comes, i get insane FPS drops, i found solution, just turn off firework particles, but I can't know when will smash come, and i really need firework particles for Static Laser or Milk Spiral.If anyone knows any mod or solution please tell me, because it's anoying to always go in settings to turn it off or turn it on.

    Thanks for reading!
    -xCyclone
     
    Posted Feb 6, 2019
  2. I'm not sure if this solution will work, but it's what helped me when I had this issue. First check how much ram your computer will allow by going to settings > system > about. Then open your Minecraft launcher and go to launcher options. Click the switch at the top that says advanced settings to turn it on. Then proceed to the game profile you want to edit and enter it. Go down to JVM arguments and click the switch to allow you to edit it. you will most likely see a. "-Xmx2G ", or, "-X1G" Change that number within it to a slightly higher number than your computer can handle to allocate more RAM to your game. For example, mine would say "-Xmx4g" instead of "-Xmx2g". This should help your Minecraft run smoother.

    If that option doesn't work, there are mods such as optifine that can help improve FPS and include more settings in the options menu to cancel to help make gameplay smoother without noticing the difference.

    I hope I could be of some help, let me know if these don't work. Thank you!
     
    Posted Feb 6, 2019
  3. First of all, thanks for help!
    Second, i already allocated 2gb of my 4gb, and i dont know am i able to put 3gb.I use labymod, but with it and without it results are the same.
     
    OP OP
    OP OP Posted Feb 6, 2019

  4. Have you also tried to lower down Render Distance? That is normally a huge cause of lag as well when running faster pace games. Also try to reduce settings such as fancy to fast, and turn clouds off as well. Perhaps also turn off smooth lighting and fog. Maybe turn particles to decreased, not off. Since particles seems to be your main issue.
     
    Posted Feb 6, 2019
  5. I have all these settings on off, but render distance isnt my problem, because i play at 120 fps and it drops to 20-30, ill try decrasing particles, ty for help
     
    OP OP
    OP OP Posted Feb 6, 2019
  6. Hey there! 2GB is enough for vanilla Minecraft. Your performance should now mostly depend on your CPU and GPU.

    You should try and download optifine. You can actually download it as an "addon" with labymod! Simply press ESC, go to Labymod settings and find Optifine under the add-on tab.

    Alternatively, you can try and invest into a better CPU. I know this may be a bit crazy, but if your CPU just can't handle Minecraft, then it's just better to buy a better one. If you're using shaders (which I suppose you're not), then Minecraft would be GPU dependent.

    Try lowering your settings overall. If you download optifine, you have a lot more options regarding performance. Just set the settings overall lower, and it should help.

    I hope I was able to help you. If you need any further assistance regarding your FPS drop issue, don't hesitate to message me!
     
    Posted Feb 6, 2019
  7. Everybody thanks for helping, i am not stupid to don't know these steps which you said earlier.My CPU is good, so I will just try to decrase particles in settings.
     
    OP OP
    OP OP Posted Feb 6, 2019
    Waspter likes this.
  8. Jam
    x

    Generally the fireworks tend to kill frames on weaker computers and laptops in all versions, but particularly in 1.13 for some reason there is a glitch where the crystal duplicates the fireworks coming down, resulting in like 10x the particle effects and a huge lag effect.

    1.8 - 1.12 doesn't have this but 1.13 does have laggier crystal spawns so just be aware with that. It might be your game version but you shouldn't play SSM on 1.9+ anyways there are many disadvantages...
     
    Posted Feb 6, 2019
  9. If you're using LabyMod make sure to turn Optifine on, please make sure that you have your maximum FPS in settings at minimum 250, preferably max for a bad computer. This was the fix for my brother's old laptop. Additionally, I recommend refreshing chunks with F3+S every once in a while, in no way is it a permanent fix though. I highly recommend that you use 1.8.9, as stated above, you are at a major disadvantage especially when it comes to SSM. If you need any further assistance, PM me as I have dealt with a similar case in helping my younger brother with his old laptop as I stated.
     
    Posted Feb 6, 2019
  10. If you use an HD texture pack it might cause lag. I would recommend trying to find a good texture pack that doesn't make you lag (that is if you use texture). Maybe find a pack that is 32x32 or 64x64.
     
    Posted Feb 6, 2019
  11. I use Ace's blank pack, basically default
     
    OP OP
    OP OP Posted Feb 6, 2019
  12. Okay, maybe like @Jam said, use 1.8 to play, and that might clear up some lag. It also has better PVP.
     
    Posted Feb 6, 2019
  13. I do, for me, 1.8 is more optimized than newer versions
     
    OP OP
    OP OP Posted Feb 6, 2019
  14. Oh, well sorry I couldn't help, I would read @Abood 's response and see if doing that helps. Have a great day, and I hope you can figure something out!
     
    Posted Feb 6, 2019
  15. Thanks for helping Snowwii.
    Have a nice day.
     
    OP OP
    OP OP Posted Feb 6, 2019
    Jet Starglaze and cernsie like this.
  16. Complete guide on how to improve FPS:

    1. Download Labymod/Optifine for 1.8.9, download the newest version of Labymod 3.4
    2. Once open, close your MC and go to the launcher. Go to "Launch Options" and set "Advanced settings" to ON.
    3. Click on your labymod profile and scroll down to "JVM Arguments".
    4. You will see this text there:
    -Xmx1G -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=32M

    Change the -Xmx1G (the part I put in bold up there). The 1 should be changed to half of your computer's allocated RAM. My PC has 16 gigs of RAM, so I use -Xmx8G.

    5. Open Minecraft. Go to your Optifine settings and change all these:
    Important: FAST RENDER IS ON, Labymod will tell you to turn it off. Just press "skip anyway" to access Labymod, since that option must be kept on.

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    In your Labymod settings, try using as little modules as possible and don't use many addons. Set most of your animations to 1.7 instead of 1.8. Never use shaderpacks or motion blurr.
    One good tip is to change your pack to a 32x, 16x, or even 8x PvP pack. Those can help with FPS.

    Important: Close all other apps while playing.
    Go to Task Manager and right click on MC. Go to "expand" and then it will take you to another page. Here, you can set performance priority of the app. Set Minecraft to "High Priority".

    Alternatively, if none of this works, download razer cortex (the app next to the green cloud on my taskbar). This is what's called a game booster. It shuts down everything on your PC, even your volume settings in order to focus literally everything your PC has on the game itself. You will cap about 100-200 frames higher but the gameplay experience will be a bit more rugged (can't change volume, can't open other apps). I use it for Overwatch and although I have a weak PC, I can cap a smooth 60FPS Vsync at 1440p. It's probably the best choice you have.
    Turn on everything in the game booster.


    [​IMG]


    Capping FPS lowers the actual value that you will be able to achieve with your PC. Let's say my PC is capable of getting 120 but I cap 60, the value won't stay 60 - it will fluctuate down to 40 and 50 even though it is more than powerful enough to handle what's going on in the game. If you're going to change FPS settings either set it to unlimited or choose Vsync. Vsync is always better, though, as it syncs frames together to smoothen gameplay, while also setting an optimum of 60fps (this is different to capping FPS).

    One last notice: Lag (Ping/MS) can greatly affect your PC's performance. If your internet is slow, you're more likely to have FPs issues.

    Good luck!
    -High <3
     
    Posted Feb 7, 2019,
    Last edited Feb 7, 2019
    Bozidqr and cernsie like this.
  17. Never change your ram value to more than 3gb of ram. When it is 3gb of ram, the performance will mostly depend on your CPU and GPU. By allocating more ram than needed (2gb or 3), you're making it so that Java builds more data before removing it. That's good, right? Not really. Java uses this thing called a "Garbage collector". Data that is no longer needed gets purged up to free more ram for other data. When you allocate more ram, you more data build up before removing it. The problem is, when you remove too much data at once, Java will not have enough time to render the next frame and you will get a lagspike.

    You should allocate around 2-3 GB of ram, because then, Java won't be bottlenecked. Minecraft will not depend mostly on your CPU and GPU.
     
    Posted Feb 7, 2019
    Bozidqr likes this.
  18. Thanks for help everyone, it runs better a lot!
     
    OP OP
    OP OP Posted Feb 7, 2019
    Jet Starglaze and xOeuf like this.
  19. Hey!

    I am glad to hear that you have resolved your problem! The players above me have given some great advice on how to optimise your game. Some good suggestions are using Optifine or any other allowed modifications. However I would like to remind you that we do only allow some mods and these can be found here - www.mineplex.com/rules

    If you have any more questions please feel free to message me on the forums.

    Thread Locked || Concern Addressed
     
    Posted Feb 7, 2019
    xOeuf likes this.
Thread Status:
Not open for further replies.

Share This Page