• 451 Players on Java
  • us.mineplex.com
  • 5842 Players Online
  • 5391 Players on Bedrock
  • pe.mineplex.com
!
Attention Internet Explorer Users
To have the best user experience on our site please consider upgrading to Google Chrome or Mozilla Firefox

Why not make Mineplex Java a 1.8.9 server?

Discussion in 'Server Discussion' started by Tanish_, Jul 25, 2021.

  1. Since we all know, Mineplex is compatible with versions 1.8.9-1.17. So why is it that, inspite of being compatible with the newer versions, Mineplex is the buggiest on those versions? In fact, Mineplex is even stated as a 1.17 server in some websites. So people think they can play with 1.17 on Mineplex with no problem, and when they have a terrible experience, they think that this is how the server is. Thus they move on with other servers, forgetting about Mineplex. In my opinion, I feel the devs are simply updating to the newer versions without really checking if anything is fine or not, and they have been lying to us all this time.

    I would recommend to at least make the server 1.8.9 only until everything is fixed and we can actually play on newer versions without any problem.

    Or perhaps never update it to newer versions at all. I think the majority of Mineplex players are 1.8.9, so I don't see why we would need to play on 1.17.
     
    Posted Jul 25, 2021
  2. Hey!

    The server is already ran on 1.8.9 and it is the most stable version to play on. Mineplex is most buggy with newer versions (1.17 especially) because that version of Minecraft just came out so of course there’s going to be bugs.

    I don’t think making the server exclusive to 1.8.9 is necessary since 1.17 is only buggy because it just came out and needs time to be worked on. Yes, the majority of the players probably play on 1.8.9 but we should still allow people to play on newer versions. The glitches with newer versions are not permanent, therefore, we shouldn’t take away the ability to play on it as it will be fixed. I can see why it would be good making the server only compatible with 1.8.9 due to the bugs but I just don’t see it as a good idea since there are other versions (for example, 1.11.2) that people play on.

    The issue with 1.17 is well known and is hopefully being worked on.
     
    Posted Jul 25, 2021
  3. Well it's not only 1.17 that I am talking about here. Before 1.17 came, I experienced bugs in versions 1.16 and 1.12 too. Getting stuck in a block, not being able to use compass in lobbies, sounds just broken in games, etc. These bugs are common in basically every new version after 1.8.9 (I know this because I played on every version once).
     
    OP OP
    OP OP Posted Jul 25, 2021
  4. This implies that we actually get bug fixes on a regular basis. Back when I switched to newer versions to play skyfall, bugs such as shields, bouncy arrows, and doors not opening were left untouched for the entire year or so I played on those versions. And that was back when we had 8kish players and a bigger dev team. From what I hear, 1.17 is practically unplayable and I think it reflects far worse on the server to present itself like that than to just be 1.8.9. Then again, I do know there are plenty of people who play on newer versions regardless (masochists??) and we probably don't want to hurt our already dwindling playercount.
     
    Posted Jul 25, 2021
    Tanish_ likes this.
  5. Because not running the latest version tends to cut your potential (and existing playerbase) significantly.
     
    Posted Jul 25, 2021
    Tanish_ and SpitefulNick like this.
  6. playing on any version other than 1.8.9 handicaps a player to a very extreme extent. the bugs are god awful and are either not fixable or simply ignored since devs clearly do not seem to exist; there are legitimately games that you cannot play at all. like Survival Games, which automatically kicks players as soon as the countdown ends in game. this means dozens upon dozens if not hundreds of players are getting kicked simply because they are on the latest version. my guess would be that the majority of minecraft players as a whole are using the most recent update they can use. this removes an insane amount of player volume that could potentially fill the server. I believe it is one of the most influential reasons as to why the player count is barely reaching 600, on a SUNDAY...but of course the biggest reason we all can mostly agree to is that the higher ups don't give a damn
     
    Posted Jul 26, 2021
    Tanish_ likes this.
  7. Hey, we won't be dropping support for every single version except 1.8-1.8.9 for multiple reasons, but one of the ones I'd like to mention is the fact that the majority of the playerbase isn't actually on 1.8. Sure, if you check the versions of players in a Cake Wars lobby you might find that the majority are actually 1.8, but if you check the entire server you'll see the most popular versions are 1.12 and the most recent version. Just from knowing that, you can imagine that dropping support for those versions + everything in between would absolutely kill the player count.

    We were thinking of dropping support for certain versions, though, these being 1.10, 1.11, etc. However, we do need a Developer to agree and do it.

    As for 1.17 bugs, we are all aware of them...and no one is fixing them. It was out of even QA/T's control at that point. I wish we could have done and could do more.
     
    Posted Jul 26, 2021
    Evgeen likes this.
  8. That's fine, but what about the bugs that still exist in versions like 1.12, 1.16, etc.? Perhaps in my opinion this is only creating false assumptions about the server among those who use newer versions/versions above 1.8. Hence you tend to see a lot of comments in public chat saying 'Mineplex sucks!!!' and other similar comments.
     
    OP OP
    OP OP Posted Jul 26, 2021

Share This Page